The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / rrdtool / rrdtool.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/rrdtool/rrdtool.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/rrdtool/rrdtool.mk
new file mode 100644 (file)
index 0000000..e422694
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# rrdtool
+#
+################################################################################
+
+RRDTOOL_VERSION = 1.2.30
+RRDTOOL_SITE = http://oss.oetiker.ch/rrdtool/pub
+RRDTOOL_LICENSE = GPLv2+ with FLOSS license exceptions as explained in COPYRIGHT
+RRDTOOL_LICENSE_FILES = COPYING COPYRIGHT
+
+RRDTOOL_DEPENDENCIES = host-pkgconf freetype libart libpng zlib
+RRDTOOL_AUTORECONF = YES
+RRDTOOL_INSTALL_STAGING = YES
+RRDTOOL_CONF_ENV = \
+       rd_cv_ieee_works=yes \
+       rd_cv_null_realloc=nope \
+       ac_cv_func_mmap_fixed_mapped=yes
+RRDTOOL_CONF_OPTS = \
+       --disable-perl \
+       --disable-python \
+       --disable-ruby \
+       --disable-tcl \
+       --program-transform-name='' \
+       $(if $(BR2_TOOLCHAIN_HAS_THREADS),,--disable-pthread)
+RRDTOOL_MAKE = $(MAKE1)
+
+define RRDTOOL_REMOVE_EXAMPLES
+       rm -rf $(TARGET_DIR)/usr/share/rrdtool/examples
+endef
+
+RRDTOOL_POST_INSTALL_TARGET_HOOKS += RRDTOOL_REMOVE_EXAMPLES
+
+$(eval $(autotools-package))