The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / rpi-userland / rpi-userland.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/rpi-userland/rpi-userland.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/rpi-userland/rpi-userland.mk
new file mode 100644 (file)
index 0000000..20a6af0
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# rpi-userland
+#
+################################################################################
+
+RPI_USERLAND_VERSION = 8f542a1647e6f88f254eadd9ad6929301c81913b
+RPI_USERLAND_SITE = $(call github,raspberrypi,userland,$(RPI_USERLAND_VERSION))
+RPI_USERLAND_LICENSE = BSD-3c
+RPI_USERLAND_LICENSE_FILES = LICENCE
+RPI_USERLAND_INSTALL_STAGING = YES
+RPI_USERLAND_CONF_OPTS = -DVMCS_INSTALL_PREFIX=/usr \
+       -DCMAKE_C_FLAGS="-DVCFILED_LOCKFILE=\\\"/var/run/vcfiled.pid\\\""
+
+RPI_USERLAND_PROVIDES = libegl libgles libopenmax libopenvg
+
+ifeq ($(BR2_PACKAGE_RPI_USERLAND_START_VCFILED),y)
+define RPI_USERLAND_INSTALL_INIT_SYSV
+       $(INSTALL) -m 0755 -D package/rpi-userland/S94vcfiled \
+               $(TARGET_DIR)/etc/init.d/S94vcfiled
+endef
+endif
+
+define RPI_USERLAND_POST_TARGET_CLEANUP
+       rm -f $(TARGET_DIR)/etc/init.d/vcfiled
+       rm -f $(TARGET_DIR)/usr/share/install/vcfiled
+       rmdir --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share/install
+       rm -Rf $(TARGET_DIR)/usr/src
+endef
+RPI_USERLAND_POST_INSTALL_TARGET_HOOKS += RPI_USERLAND_POST_TARGET_CLEANUP
+
+$(eval $(cmake-package))