The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / rpcbind / rpcbind.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/rpcbind/rpcbind.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/rpcbind/rpcbind.mk
new file mode 100644 (file)
index 0000000..7bfb1e2
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# rpcbind
+#
+################################################################################
+
+RPCBIND_VERSION = 0.2.1
+RPCBIND_SITE = http://downloads.sourceforge.net/project/rpcbind/rpcbind/$(RPCBIND_VERSION)
+RPCBIND_SOURCE = rpcbind-$(RPCBIND_VERSION).tar.bz2
+RPCBIND_LICENSE = BSD-3c
+RPCBIND_LICENSE_FILES = COPYING
+
+RPCBIND_CONF_ENV += \
+       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/tirpc/"
+RPCBIND_DEPENDENCIES += libtirpc
+RPCBIND_CONF_OPTS += --with-rpcuser=root
+
+define RPCBIND_INSTALL_INIT_SYSV
+       $(INSTALL) -m 0755 -D package/rpcbind/S30rpcbind \
+               $(TARGET_DIR)/etc/init.d/S30rpcbind
+endef
+
+$(eval $(autotools-package))