The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / redis / redis.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/redis/redis.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/redis/redis.mk
new file mode 100644 (file)
index 0000000..4cad061
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# redis
+#
+################################################################################
+
+REDIS_VERSION = 2.8.19
+REDIS_SITE = http://download.redis.io/releases
+REDIS_LICENSE = BSD-3c (core); MIT and BSD family licenses (Bundled components)
+REDIS_LICENSE_FILES = COPYING
+
+# Redis doesn't support DESTDIR (yet, see
+# https://github.com/antirez/redis/pull/609).  We set PREFIX
+# instead.
+REDIS_BUILDOPTS = $(TARGET_CONFIGURE_OPTS) \
+       PREFIX=$(TARGET_DIR)/usr MALLOC=libc \
+
+define REDIS_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(REDIS_BUILDOPTS) -C $(@D)
+endef
+
+define REDIS_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(REDIS_BUILDOPTS) -C $(@D) \
+               LDCONFIG=true install
+endef
+
+$(eval $(generic-package))