The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / readline / readline.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/readline/readline.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/readline/readline.mk
new file mode 100644 (file)
index 0000000..c004899
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# readline
+#
+################################################################################
+
+READLINE_VERSION = 6.3
+READLINE_SITE = $(BR2_GNU_MIRROR)/readline
+READLINE_INSTALL_STAGING = YES
+READLINE_DEPENDENCIES = ncurses
+HOST_READLINE_DEPENDENCIES = host-ncurses
+READLINE_CONF_ENV = bash_cv_func_sigsetjmp=yes \
+       bash_cv_wcwidth_broken=no
+READLINE_LICENSE = GPLv3+
+READLINE_LICENSE_FILES = COPYING
+
+define READLINE_PURGE_EXAMPLES
+       rm -rf $(TARGET_DIR)/usr/share/readline
+endef
+
+READLINE_POST_INSTALL_TARGET_HOOKS += READLINE_PURGE_EXAMPLES
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))