The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / rdesktop / rdesktop.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/rdesktop/rdesktop.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/rdesktop/rdesktop.mk
new file mode 100644 (file)
index 0000000..79187b5
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# rdesktop
+#
+################################################################################
+
+RDESKTOP_VERSION = 1.8.3
+RDESKTOP_SITE = http://downloads.sourceforge.net/project/rdesktop/rdesktop/$(RDESKTOP_VERSION)
+RDESKTOP_DEPENDENCIES = host-pkgconf openssl xlib_libX11 xlib_libXt \
+       $(if $(BR2_PACKAGE_ALSA_LIB_PCM),alsa-lib) \
+       $(if $(BR2_PACKAGE_LIBAO),libao) \
+       $(if $(BR2_PACKAGE_LIBSAMPLERATE),libsamplerate)
+RDESKTOP_CONF_OPTS = --with-openssl=$(STAGING_DIR)/usr --disable-credssp
+RDESKTOP_LICENSE = GPLv3+
+RDESKTOP_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_PCSC_LITE),y)
+RDESKTOP_DEPENDENCIES += pcsc-lite
+else
+RDESKTOP_CONF_OPTS += --disable-smartcard
+endif
+
+$(eval $(autotools-package))