The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / ramsmp / ramsmp.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/ramsmp/ramsmp.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/ramsmp/ramsmp.mk
new file mode 100644 (file)
index 0000000..6098376
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# ramsmp
+#
+################################################################################
+
+RAMSMP_VERSION = 3.5.0
+RAMSMP_SITE = http://www.alasir.com/software/ramspeed
+RAMSMP_ARCH = $(if $(BR2_i386),i386)$(if $(BR2_x86_64),x86_64)
+RAMSMP_LICENSE = Alasir License
+RAMSMP_LICENSE_FILES = LICENCE
+
+define RAMSMP_BUILD_CMDS
+       cp -f package/ramsmp/Makefile $(@D)
+       $(TARGET_CONFIGURE_OPTS) make -C $(@D) $(RAMSMP_ARCH)
+endef
+
+define RAMSMP_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/ramsmp $(TARGET_DIR)/usr/bin/ramsmp
+endef
+
+$(eval $(generic-package))