The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / qt5 / qt5.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/qt5/qt5.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/qt5/qt5.mk
new file mode 100644 (file)
index 0000000..e7485e1
--- /dev/null
@@ -0,0 +1,22 @@
+QT5_VERSION_MAJOR = 5.4
+QT5_VERSION = $(QT5_VERSION_MAJOR).1
+QT5_SITE = http://download.qt.io/official_releases/qt/$(QT5_VERSION_MAJOR)/$(QT5_VERSION)/submodules
+include $(sort $(wildcard package/qt5/*/*.mk))
+
+define QT5_LA_PRL_FILES_FIXUP
+       for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.la"); do \
+               $(SED)  "s:$(BASE_DIR):@BASE_DIR@:g" \
+                       -e "s:$(STAGING_DIR):@STAGING_DIR@:g" \
+                       -e "s:\(['= ]\)/usr:\\1@STAGING_DIR@/usr:g" \
+                       -e "s:@STAGING_DIR@:$(STAGING_DIR):g" \
+                       -e "s:@BASE_DIR@:$(BASE_DIR):g" \
+                       $$i ; \
+               $(SED) "/^dependency_libs=/s%-L/usr/lib %%g" $$i ; \
+       done
+       for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.prl"); do \
+               $(SED) "s%-L/usr/lib%%" $$i; \
+       done
+endef
+
+# Variable for other Qt applications to use
+QT5_QMAKE = $(HOST_DIR)/usr/bin/qmake -spec devices/linux-buildroot-g++