The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / qlibc / qlibc.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/qlibc/qlibc.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/qlibc/qlibc.mk
new file mode 100644 (file)
index 0000000..6a747e4
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# qlibc
+#
+################################################################################
+
+QLIBC_VERSION = v2.1.6
+QLIBC_SITE = $(call github,wolkykim,qlibc,$(QLIBC_VERSION))
+QLIBC_LICENSE = BSD-2c
+QLIBC_LICENSE_FILES = COPYING
+
+# We're patching configure.ac
+QLIBC_AUTORECONF = YES
+QLIBC_INSTALL_STAGING = YES
+QLIBC_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+
+# The configure.ac checks for these use AC_CHECK_FILE() which doesn't
+# work for cross-compilation. If someone wants to enable the support
+# for OpenSSL or MySQL, some changes to the configure.ac will be
+# needed.
+QLIBC_CONF_OPTS = --without-mysql --without-openssl
+
+$(eval $(autotools-package))