The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / python3 / 104-optional-tk.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/python3/104-optional-tk.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/python3/104-optional-tk.patch
new file mode 100644 (file)
index 0000000..8a852c5
--- /dev/null
@@ -0,0 +1,66 @@
+Add an option to disable the tk module
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+
+---
+ Makefile.pre.in |   14 +++++++++++---
+ configure.ac    |    9 +++++++++
+ 2 files changed, 20 insertions(+), 3 deletions(-)
+
+Index: b/Makefile.pre.in
+===================================================================
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -1140,7 +1140,7 @@
+ EXTRAPLATDIR= @EXTRAPLATDIR@
+ MACHDEPS=     $(PLATDIR) $(EXTRAPLATDIR)
+ XMLLIBSUBDIRS=  xml xml/dom xml/etree xml/parsers xml/sax
+-LIBSUBDIRS=   tkinter \
++LIBSUBDIRS=   \
+               site-packages \
+               asyncio \
+               collections concurrent concurrent/futures encodings \
+@@ -1158,8 +1158,7 @@
+               venv venv/scripts venv/scripts/posix \
+               curses $(MACHDEPS)
+-TESTSUBDIRS =         tkinter/test tkinter/test/test_tkinter tkinter/test/test_ttk \
+-              test test/test_asyncio \
++TESTSUBDIRS =         test test/test_asyncio \
+               test/test_email test/test_email/data \
+               test/test_json \
+               test/audiodata \
+@@ -1213,6 +1212,12 @@
+ TESTSUBDIRS += sqlite3/test
+ endif
++ifeq (@TK@,yes)
++LIBSUBDIRS += tkinter
++TESTSUBDIRS += tkinter/test tkinter/test/test_tkinter \
++      tkinter/test/test_ttk
++endif
++
+ ifeq (@TEST_MODULES@,yes)
+ LIBSUBDIRS += $(TESTSUBDIRS)
+ endif
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -2684,6 +2684,15 @@
+    DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
+ fi
++AC_SUBST(TK)
++AC_ARG_ENABLE(tk,
++      AS_HELP_STRING([--disable-tk], [disable tk]),
++      [ TK="${enableval}" ], [ TK=yes ])
++
++if test "$TK" = "no"; then
++   DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
++fi
++
+ AC_SUBST(PYDOC)
+ AC_ARG_ENABLE(pydoc,