The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / python3 / 013-abort-on-failed-modules.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/python3/013-abort-on-failed-modules.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/python3/013-abort-on-failed-modules.patch
new file mode 100644 (file)
index 0000000..5ad86fb
--- /dev/null
@@ -0,0 +1,21 @@
+Abort on failed module build
+
+When building a Python module fails, the setup.py script currently
+doesn't exit with an error, and simply continues. This is not a really
+nice behavior, so this patch changes setup.py to abort with an error,
+so that the build issue is clearly noticeable.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/setup.py
+===================================================================
+--- a/setup.py
++++ b/setup.py
+@@ -284,6 +284,7 @@
+             print("Failed to build these modules:")
+             print_three_column(failed)
+             print()
++            sys.exit(1)
+     def build_extension(self, ext):