The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / python / 112-optional-bzip2.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/python/112-optional-bzip2.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/python/112-optional-bzip2.patch
new file mode 100644 (file)
index 0000000..3a646e1
--- /dev/null
@@ -0,0 +1,24 @@
+Add an option to disable the bz2 module
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.in |    6 ++++++
+ 1 file changed, 6 insertions(+)
+
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -2662,6 +2662,12 @@
+            DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl"
+         fi])
++AC_ARG_ENABLE(bz2,
++       AS_HELP_STRING([--disable-bz2], [disable BZIP2]),
++       [ if test "$enableval" = "no"; then
++            DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bz2"
++         fi])
++
+ AC_ARG_ENABLE(dbm,
+       AS_HELP_STRING([--disable-dbm], [disable DBM]),
+       [ if test "$enableval" = "no"; then