The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / python / 111-optional-ssl.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/python/111-optional-ssl.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/python/111-optional-ssl.patch
new file mode 100644 (file)
index 0000000..72891cd
--- /dev/null
@@ -0,0 +1,25 @@
+Add an option to disable the ssl module
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ configure.in |    6 ++++++
+ 1 file changed, 6 insertions(+)
+
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -2656,6 +2656,12 @@
+            DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
+         fi])
++AC_ARG_ENABLE(ssl,
++      AS_HELP_STRING([--disable-ssl], [disable SSL]),
++      [ if test "$enableval" = "no"; then
++           DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl"
++        fi])
++
+ AC_ARG_ENABLE(dbm,
+       AS_HELP_STRING([--disable-dbm], [disable DBM]),
+       [ if test "$enableval" = "no"; then