The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / python / 011-remove-python-symlink.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/python/011-remove-python-symlink.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/python/011-remove-python-symlink.patch
new file mode 100644 (file)
index 0000000..b0548c3
--- /dev/null
@@ -0,0 +1,30 @@
+Remove the python symlink install rules.
+
+The python symlink installation will be handled by Buildroot itself, because
+Buildroot needs to control to what python interpreter (python2 or python3) the
+python symlink points to.
+
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+
+Index: b/Makefile.pre.in
+===================================================================
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -890,17 +890,10 @@
+ #  $(PYTHON) -> python2 -> python$(VERSION))
+ # Also create equivalent chains for other installed files
+ bininstall:   altbininstall
+-      -if test -f $(DESTDIR)$(BINDIR)/$(PYTHON) -o -h $(DESTDIR)$(BINDIR)/$(PYTHON); \
+-      then rm -f $(DESTDIR)$(BINDIR)/$(PYTHON); \
+-      else true; \
+-      fi
+-      (cd $(DESTDIR)$(BINDIR); $(LN) -s python2$(EXE) $(PYTHON))
+       -rm -f $(DESTDIR)$(BINDIR)/python2$(EXE)
+       (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python2$(EXE))
+       -rm -f $(DESTDIR)$(BINDIR)/python2-config
+       (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python2-config)
+-      -rm -f $(DESTDIR)$(BINDIR)/python-config
+-      (cd $(DESTDIR)$(BINDIR); $(LN) -s python2-config python-config)
+       -test -d $(DESTDIR)$(LIBPC) || $(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC)
+       -rm -f $(DESTDIR)$(LIBPC)/python2.pc
+       (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python2.pc)