The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / python-pypcap / python-pypcap.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/python-pypcap/python-pypcap.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/python-pypcap/python-pypcap.mk
new file mode 100644 (file)
index 0000000..89f2dc1
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# python-pypcap
+#
+################################################################################
+
+PYTHON_PYPCAP_VERSION = 102
+PYTHON_PYPCAP_SITE = https://pypcap.googlecode.com/svn/trunk
+PYTHON_PYPCAP_SITE_METHOD = svn
+PYTHON_PYPCAP_LICENSE = BSD-3c
+PYTHON_PYPCAP_LICENSE_FILES = LICENSE
+PYTHON_PYPCAP_SETUP_TYPE = distutils
+PYTHON_PYPCAP_DEPENDENCIES = host-python-pyrex libpcap
+
+define PYTHON_PYPCAP_CONFIGURE_CMDS
+       $(HOST_DIR)/usr/bin/pyrexc $(@D)/pcap.pyx
+       (cd $(@D); \
+               $(HOST_DIR)/usr/bin/python setup.py \
+               config --with-pcap=$(STAGING_DIR)/usr)
+endef
+
+$(eval $(python-package))