The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / python-pycrypto / 0001-remove-incorrect-header-path.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/python-pycrypto/0001-remove-incorrect-header-path.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/python-pycrypto/0001-remove-incorrect-header-path.patch
new file mode 100644 (file)
index 0000000..9268d31
--- /dev/null
@@ -0,0 +1,21 @@
+Do not use /usr/include for headers
+
+Using /usr/include is wrong when doing cross-compilation, so get rid
+of it, and rely on the compiler to use the appropriate default paths
+for headers.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/setup.py
+===================================================================
+--- a/setup.py
++++ b/setup.py
+@@ -370,7 +370,7 @@
+       'ext_modules': plat_ext + [
+             # _fastmath (uses GNU mp library)
+             Extension("Crypto.PublicKey._fastmath",
+-                      include_dirs=['src/','/usr/include/'],
++                      include_dirs=['src/'],
+                       libraries=['gmp'],
+                       sources=["src/_fastmath.c"]),