The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / python-lxml / python-lxml.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/python-lxml/python-lxml.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/python-lxml/python-lxml.mk
new file mode 100644 (file)
index 0000000..5dcc4ca
--- /dev/null
@@ -0,0 +1,31 @@
+################################################################################
+#
+# python-lxml
+#
+################################################################################
+
+PYTHON_LXML_VERSION = 3.4.2
+PYTHON_LXML_SITE = http://lxml.de/files
+PYTHON_LXML_SOURCE = lxml-$(PYTHON_LXML_VERSION).tgz
+
+# Not including the GPL, because it is used only for the test scripts.
+PYTHON_LXML_LICENSE = BSD-3c, Others
+PYTHON_LXML_LICENSE_FILES = \
+       LICENSES.txt \
+       doc/licenses/BSD.txt \
+       doc/licenses/elementtree.txt \
+       src/lxml/isoschematron/resources/rng/iso-schematron.rng
+
+# python-lxml can use either setuptools, or distutils as a fallback.
+# So, we use setuptools.
+PYTHON_LXML_SETUP_TYPE = setuptools
+
+PYTHON_LXML_DEPENDENCIES = libxml2 libxslt zlib
+
+# python-lxml needs these scripts in order to properly detect libxml2 and
+# libxslt compiler and linker flags
+PYTHON_LXML_BUILD_OPTS = \
+       --with-xslt-config=$(STAGING_DIR)/usr/bin/xslt-config \
+       --with-xml2-config=$(STAGING_DIR)/usr/bin/xml2-config
+
+$(eval $(python-package))