The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / pure-ftpd / pure-ftpd.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/pure-ftpd/pure-ftpd.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/pure-ftpd/pure-ftpd.mk
new file mode 100644 (file)
index 0000000..5dbcaae
--- /dev/null
@@ -0,0 +1,35 @@
+################################################################################
+#
+# pure-ftpd
+#
+################################################################################
+
+PURE_FTPD_VERSION = 1.0.36
+PURE_FTPD_SITE = http://download.pureftpd.org/pub/pure-ftpd/releases
+PURE_FTPD_LICENSE = ISC
+PURE_FTPD_LICENSE_FILES = COPYING
+PURE_FTPD_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+
+PURE_FTPD_CONF_OPTS = \
+       --with-altlog \
+       --with-puredb \
+       --with-rfc2640
+
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+PURE_FTPD_CONF_OPTS += --with-capabilities
+PURE_FTPD_DEPENDENCIES += libcap
+else
+PURE_FTPD_CONF_OPTS += --without-capabilities
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+PURE_FTPD_CONF_OPTS += --with-tls
+PURE_FTPD_DEPENDENCIES += openssl
+ifeq ($(BR2_STATIC_LIBS),y)
+PURE_FTPD_CONF_ENV += LIBS='-lssl -lcrypto -lz'
+endif
+else
+PURE_FTPD_CONF_OPTS += --without-tls
+endif
+
+$(eval $(autotools-package))