The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / psplash / psplash.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/psplash/psplash.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/psplash/psplash.mk
new file mode 100644 (file)
index 0000000..85c0fb8
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# psplash
+#
+################################################################################
+
+PSPLASH_VERSION = 14c8f7b705de944beb4de3f296506d80871e410f
+PSPLASH_SITE = git://git.yoctoproject.org/psplash
+PSPLASH_LICENSE = GPLv2+
+PSPLASH_AUTORECONF = YES
+
+define PSPLASH_INSTALL_INIT_SYSTEMD
+       $(INSTALL) -D -m 644 package/psplash/psplash-start.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/psplash-start.service
+       $(INSTALL) -d $(TARGET_DIR)/etc/systemd/system/sysinit.target.wants
+       ln -sf  ../../../../usr/lib/systemd/system/psplash-start.service \
+                $(TARGET_DIR)/etc/systemd/system/sysinit.target.wants/
+
+       $(INSTALL) -D -m 644 package/psplash/psplash-quit.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/psplash-quit.service
+       $(INSTALL) -d $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -sf  ../../../../usr/lib/systemd/system/psplash-quit.service \
+                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/
+endef
+
+$(eval $(autotools-package))