The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / protobuf-c / protobuf-c.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/protobuf-c/protobuf-c.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/protobuf-c/protobuf-c.mk
new file mode 100644 (file)
index 0000000..d73eb25
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# protobuf-c
+#
+################################################################################
+
+PROTOBUF_C_VERSION = v1.0.0-rc1
+PROTOBUF_C_SITE = $(call github,protobuf-c,protobuf-c,$(PROTOBUF_C_VERSION))
+PROTOBUF_C_DEPENDENCIES = host-protobuf-c
+HOST_PROTOBUF_C_DEPENDENCIES = host-protobuf host-pkgconf
+PROTOBUF_C_MAKE = $(MAKE1)
+PROTOBUF_C_CONF_OPTS = --disable-protoc
+PROTOBUF_C_INSTALL_STAGING = YES
+PROTOBUF_C_LICENSE = BSD-2c
+PROTOBUF_C_LICENSE_FILES = LICENSE
+PROTOBUF_C_AUTORECONF = YES
+HOST_PROTOBUF_C_AUTORECONF = YES
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))