The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / pptp-linux / 0002-fix-parallel-build.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/pptp-linux/0002-fix-parallel-build.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/pptp-linux/0002-fix-parallel-build.patch
new file mode 100644 (file)
index 0000000..04a7977
--- /dev/null
@@ -0,0 +1,23 @@
+Fix parallel build issue
+
+The config.h header file must be created before being used to build
+source files that include it, especially version.c. In order for this
+to happen even in highly-parallel builds, we add a dependency of all
+object files on config.h, in order to ensure it gets generated before
+make attempts to build the object files.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -37,6 +37,8 @@
+ all: config.h $(PPTP_BIN) pptpsetup.8
++$(PPTP_OBJS): config.h
++
+ $(PPTP_BIN): $(PPTP_OBJS) $(PPTP_DEPS)
+       $(CC) -o $(PPTP_BIN) $(PPTP_OBJS) $(LDFLAGS) $(LIBS)