The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / pkg-utils.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/pkg-utils.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/pkg-utils.mk
new file mode 100644 (file)
index 0000000..99a3c1e
--- /dev/null
@@ -0,0 +1,151 @@
+################################################################################
+#
+# This file contains various utility functions used by the package
+# infrastructure, or by the packages themselves.
+#
+################################################################################
+
+# Case conversion macros. This is inspired by the 'up' macro from gmsl
+# (http://gmsl.sf.net). It is optimised very heavily because these macros
+# are used a lot. It is about 5 times faster than forking a shell and tr.
+#
+# The caseconvert-helper creates a definition of the case conversion macro.
+# After expansion by the outer $(eval ), the UPPERCASE macro is defined as:
+# $(strip $(eval __tmp := $(1))  $(eval __tmp := $(subst a,A,$(__tmp))) ... )
+# In other words, every letter is substituted one by one.
+#
+# The caseconvert-helper allows us to create this definition out of the
+# [FROM] and [TO] lists, so we don't need to write down every substition
+# manually. The uses of $ and $$ quoting are chosen in order to do as
+# much expansion as possible up-front.
+#
+# Note that it would be possible to conceive a slightly more optimal
+# implementation that avoids the use of __tmp, but that would be even
+# more unreadable and is not worth the effort.
+
+[FROM] := a b c d e f g h i j k l m n o p q r s t u v w x y z - .
+[TO]   := A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _ _
+
+define caseconvert-helper
+$(1) = $$(strip \
+       $$(eval __tmp := $$(1))\
+       $(foreach c, $(2),\
+               $$(eval __tmp := $$(subst $(word 1,$(subst :, ,$c)),$(word 2,$(subst :, ,$c)),$$(__tmp))))\
+       $$(__tmp))
+endef
+
+$(eval $(call caseconvert-helper,UPPERCASE,$(join $(addsuffix :,$([FROM])),$([TO]))))
+$(eval $(call caseconvert-helper,LOWERCASE,$(join $(addsuffix :,$([TO])),$([FROM]))))
+
+# Sanitize macro cleans up generic strings so it can be used as a filename
+# and in rules. Particularly useful for VCS version strings, that can contain
+# slashes, colons (OK in filenames but not in rules), and spaces.
+sanitize = $(subst $(space),_,$(subst :,_,$(subst /,_,$(strip $(1)))))
+
+#
+# Manipulation of .config files based on the Kconfig
+# infrastructure. Used by the BusyBox package, the Linux kernel
+# package, and more.
+#
+
+define KCONFIG_ENABLE_OPT # (option, file)
+       $(SED) "/\\<$(1)\\>/d" $(2)
+       echo '$(1)=y' >> $(2)
+endef
+
+define KCONFIG_SET_OPT # (option, value, file)
+       $(SED) "/\\<$(1)\\>/d" $(3)
+       echo '$(1)=$(2)' >> $(3)
+endef
+
+define KCONFIG_DISABLE_OPT # (option, file)
+       $(SED) "/\\<$(1)\\>/d" $(2)
+       echo '# $(1) is not set' >> $(2)
+endef
+
+# Helper functions to determine the name of a package and its
+# directory from its makefile directory, using the $(MAKEFILE_LIST)
+# variable provided by make. This is used by the *-package macros to
+# automagically find where the package is located.
+pkgdir = $(dir $(lastword $(MAKEFILE_LIST)))
+pkgname = $(lastword $(subst /, ,$(pkgdir)))
+
+# Define extractors for different archive suffixes
+INFLATE.bz2  = $(BZCAT)
+INFLATE.gz   = $(ZCAT)
+INFLATE.tbz  = $(BZCAT)
+INFLATE.tbz2 = $(BZCAT)
+INFLATE.tgz  = $(ZCAT)
+INFLATE.xz   = $(XZCAT)
+INFLATE.tar  = cat
+# suitable-extractor(filename): returns extractor based on suffix
+suitable-extractor = $(INFLATE$(suffix $(1)))
+
+# MESSAGE Macro -- display a message in bold type
+MESSAGE = echo "$(TERM_BOLD)>>> $($(PKG)_NAME) $($(PKG)_VERSION) $(call qstrip,$(1))$(TERM_RESET)"
+TERM_BOLD := $(shell tput smso)
+TERM_RESET := $(shell tput rmso)
+
+# Utility functions for 'find'
+# findfileclauses(filelist) => -name 'X' -o -name 'Y'
+findfileclauses = $(call notfirstword,$(patsubst %,-o -name '%',$(1)))
+# finddirclauses(base, dirlist) => -path 'base/dirX' -o -path 'base/dirY'
+finddirclauses = $(call notfirstword,$(patsubst %,-o -path '$(1)/%',$(2)))
+
+# Miscellaneous utility functions
+# notfirstword(wordlist): returns all but the first word in wordlist
+notfirstword = $(wordlist 2,$(words $(1)),$(1))
+
+# Needed for the foreach loops to loop over the list of hooks, so that
+# each hook call is properly separated by a newline.
+define sep
+
+
+endef
+
+# check-deprecated-variable -- throw an error on deprecated variables
+# example:
+#   $(eval $(call check-deprecated-variable,FOO_MAKE_OPT,FOO_MAKE_OPTS))
+define check-deprecated-variable # (deprecated var, new var)
+ifneq ($$(origin $(1)),undefined)
+$$(error Package error: use $(2) instead of $(1). Please fix your .mk file)
+endif
+endef
+
+#
+# legal-info helper functions
+#
+LEGAL_INFO_SEPARATOR = "::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::"
+
+define legal-warning # text
+       echo "WARNING: $(1)" >>$(LEGAL_WARNINGS)
+endef
+
+define legal-warning-pkg # pkg, text
+       echo "WARNING: $(1): $(2)" >>$(LEGAL_WARNINGS)
+endef
+
+define legal-warning-nosource # pkg, {local|override}
+       $(call legal-warning-pkg,$(1),sources not saved ($(2) packages not handled))
+endef
+
+define legal-manifest # pkg, version, license, license-files, source, url, {HOST|TARGET}
+       echo '"$(1)","$(2)","$(3)","$(4)","$(5)","$(6)"' >>$(LEGAL_MANIFEST_CSV_$(7))
+endef
+
+define legal-license-header # pkg, license-file, {HOST|TARGET}
+       printf "$(LEGAL_INFO_SEPARATOR)\n\t$(1):\
+               $(2)\n$(LEGAL_INFO_SEPARATOR)\n\n\n" >>$(LEGAL_LICENSES_TXT_$(3))
+endef
+
+define legal-license-nofiles # pkg, {HOST|TARGET}
+       $(call legal-license-header,$(1),unknown license file(s),$(2))
+endef
+
+define legal-license-file # pkg, filename, file-fullpath, {HOST|TARGET}
+       $(call legal-license-header,$(1),$(2) file,$(4)) && \
+       cat $(3) >>$(LEGAL_LICENSES_TXT_$(4)) && \
+       echo >>$(LEGAL_LICENSES_TXT_$(4)) && \
+       mkdir -p $(LICENSE_FILES_DIR_$(4))/$(1)/$(dir $(2)) && \
+       cp $(3) $(LICENSE_FILES_DIR_$(4))/$(1)/$(2)
+endef