The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / pixman / pixman.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/pixman/pixman.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/pixman/pixman.mk
new file mode 100644 (file)
index 0000000..a244ea8
--- /dev/null
@@ -0,0 +1,33 @@
+################################################################################
+#
+# pixman
+#
+################################################################################
+
+PIXMAN_VERSION = 0.32.6
+PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
+PIXMAN_LICENSE = MIT
+PIXMAN_LICENSE_FILES = COPYING
+
+PIXMAN_INSTALL_STAGING = YES
+PIXMAN_DEPENDENCIES = host-pkgconf
+PIXMAN_AUTORECONF = YES
+
+# don't build gtk based demos
+PIXMAN_CONF_OPTS = --disable-gtk
+
+# disable iwmmxt support for CPU's that don't have
+# this feature
+ifneq ($(BR2_iwmmxt),y)
+PIXMAN_CONF_OPTS += --disable-arm-iwmmxt
+endif
+
+# toolchain gets confused about TLS access through GOT (PIC), so disable TLS
+# movhi        r4, %got_hiadj(%tls_ldo(fast_path_cache))
+# {standard input}:172: Error: bad expression
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405),y)
+PIXMAN_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -DPIXMAN_NO_TLS"
+endif
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))