The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / php-yaml / php-yaml.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/php-yaml/php-yaml.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/php-yaml/php-yaml.mk
new file mode 100644 (file)
index 0000000..b6f259d
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# php-yaml
+#
+################################################################################
+
+PHP_YAML_VERSION = 1.1.1
+PHP_YAML_SOURCE = yaml-$(PHP_YAML_VERSION).tgz
+# pecl.php.net returns html with db connect failed
+PHP_YAML_SITE = http://sources.buildroot.net
+PHP_YAML_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
+       --with-yaml=$(STAGING_DIR)/usr
+# phpize does the autoconf magic
+PHP_YAML_DEPENDENCIES = libyaml php host-autoconf
+PHP_YAML_LICENSE = MIT
+PHP_YAML_LICENSE_FILES = LICENSE
+
+define PHP_YAML_PHPIZE
+       (cd $(@D); \
+               PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
+               PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
+               $(STAGING_DIR)/usr/bin/phpize)
+endef
+
+PHP_YAML_PRE_CONFIGURE_HOOKS += PHP_YAML_PHPIZE
+
+$(eval $(autotools-package))