The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / perl-gd / 0003-force.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/perl-gd/0003-force.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/perl-gd/0003-force.patch
new file mode 100644 (file)
index 0000000..0a121a9
--- /dev/null
@@ -0,0 +1,32 @@
+let @INC and @LIBPATH empty when ignore_missing_gd
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+see https://github.com/lstein/Perl-GD/pull/7
+
+Index: b/Makefile.PL
+===================================================================
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -35,13 +35,15 @@
+ }
+ push @LIBS, "-lgd";
+-@INC     = qw(-I/usr/include -I/usr/include/gd) unless @INC;
+-@LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/lib) unless @LIBPATH;
+-
+-# support for AMD64 libraries
+-if (-d '/usr/lib64') {
+-  my @libs64 = map {my $a = $_; $a=~ s/lib$/lib64/; $a} @LIBPATH;
+-  @LIBPATH = (@LIBPATH,@libs64);
++unless ($force) {
++  @INC     = qw(-I/usr/include -I/usr/include/gd) unless @INC;
++  @LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/lib) unless @LIBPATH;
++
++  # support for AMD64 libraries
++  if (-d '/usr/lib64') {
++    my @libs64 = map {my $a = $_; $a=~ s/lib$/lib64/; $a} @LIBPATH;
++    @LIBPATH = (@LIBPATH,@libs64);
++  }
+ }
+ #############################################################################################