The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / owl-linux / 0001-fix-CROSS_COMPILE-usage-in-Makefile.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/owl-linux/0001-fix-CROSS_COMPILE-usage-in-Makefile.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/owl-linux/0001-fix-CROSS_COMPILE-usage-in-Makefile.patch
new file mode 100644 (file)
index 0000000..14b4631
--- /dev/null
@@ -0,0 +1,16 @@
+Fix the owl-linux Makefile so that it protects spaces in the CROSS_COMPILE
+variable. For example, this variable will contain spaces if ccache is used.
+
+Signed-off-by: Simon Dawson <spdawson@gmail.com>
+diff -Nurp a/Makefile b/Makefile
+--- a/Makefile 2012-06-14 10:51:45.000000000 +0100
++++ b/Makefile 2012-07-20 10:46:41.636752148 +0100
+@@ -35,7 +35,7 @@ else
+       PWD := $(shell pwd)
+ default:
+-      $(MAKE) -C $(KERNELDIR) ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) M=$(PWD) MODE=$(MODE) modules
++      $(MAKE) -C $(KERNELDIR) ARCH=$(ARCH) CROSS_COMPILE="$(CROSS_COMPILE)" M=$(PWD) MODE=$(MODE) modules
+ clean: 
+       -rm -f *.o *.mod.c *.ko modules.order Module.symvers