The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / orc / orc.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/orc/orc.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/orc/orc.mk
new file mode 100644 (file)
index 0000000..0d9e78c
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# orc
+#
+################################################################################
+
+ORC_VERSION = 0.4.23
+ORC_SOURCE = orc-$(ORC_VERSION).tar.xz
+ORC_SITE = http://gstreamer.freedesktop.org/data/src/orc
+ORC_LICENSE = BSD-2c, BSD-3c
+ORC_LICENSE_FILES = COPYING
+ORC_INSTALL_STAGING = YES
+ORC_DEPENDENCIES = host-orc
+
+define ORC_REMOVE_BUGREPORT
+       rm -f $(TARGET_DIR)/usr/bin/orc-bugreport
+endef
+
+define ORC_REMOVE_DEVFILES
+       rm -f $(TARGET_DIR)/usr/bin/orcc
+endef
+
+ORC_POST_INSTALL_TARGET_HOOKS += ORC_REMOVE_BUGREPORT
+ORC_POST_INSTALL_TARGET_HOOKS += ORC_REMOVE_DEVFILES
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))