The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / opus-tools / opus-tools.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/opus-tools/opus-tools.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/opus-tools/opus-tools.mk
new file mode 100644 (file)
index 0000000..de1b439
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# opus-tools
+#
+################################################################################
+
+OPUS_TOOLS_VERSION = 0.1.9
+OPUS_TOOLS_SITE = http://downloads.xiph.org/releases/opus
+OPUS_TOOLS_LICENSE = BSD-2c
+OPUS_TOOLS_LICENSE_FILES = COPYING
+OPUS_TOOLS_CONF_OPTS = --disable-oggtest --disable-opustest
+OPUS_TOOLS_DEPENDENCIES = opus libogg host-pkgconf
+
+ifeq ($(BR2_PACKAGE_LIBPCAP),y)
+OPUS_TOOLS_DEPENDENCIES += libpcap
+endif
+
+ifeq ($(BR2_X86_CPU_HAS_SSE),y)
+OPUS_TOOLS_CONF_OPTS += --enable-sse
+else
+OPUS_TOOLS_CONF_OPTS += --disable-sse
+endif
+
+ifeq ($(BR2_PACKAGE_FLAC),y)
+OPUS_TOOLS_DEPENDENCIES += flac
+else
+OPUS_TOOLS_CONF_OPTS += --without-flac
+endif
+
+$(eval $(autotools-package))