The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / opentyrian-data / opentyrian-data.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/opentyrian-data/opentyrian-data.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/opentyrian-data/opentyrian-data.mk
new file mode 100644 (file)
index 0000000..4b879df
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# opentyrian-data
+#
+################################################################################
+
+OPENTYRIAN_DATA_VERSION = 2.1
+OPENTYRIAN_DATA_SITE = http://www.camanis.net/opentyrian
+OPENTYRIAN_DATA_SOURCE = tyrian21.zip
+OPENTYRIAN_DATA_LICENSE = Freeware
+
+define OPENTYRIAN_DATA_EXTRACT_CMDS
+       $(UNZIP) -d $(@D) $(DL_DIR)/$(OPENTYRIAN_DATA_SOURCE)
+endef
+
+define OPENTYRIAN_DATA_INSTALL_TARGET_CMDS
+       mkdir -p $(TARGET_DIR)/usr/share/opentyrian/data/
+       cp $(@D)/tyrian21/* $(TARGET_DIR)/usr/share/opentyrian/data/
+       rm -f $(TARGET_DIR)/usr/share/opentyrian/data/*.doc
+       rm -f $(TARGET_DIR)/usr/share/opentyrian/data/*.exe
+endef
+
+$(eval $(generic-package))