The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / openssh / openssh.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/openssh/openssh.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/openssh/openssh.mk
new file mode 100644 (file)
index 0000000..24af079
--- /dev/null
@@ -0,0 +1,50 @@
+################################################################################
+#
+# openssh
+#
+################################################################################
+
+OPENSSH_VERSION = 6.8p1
+OPENSSH_SITE = http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable
+OPENSSH_LICENSE = BSD-3c BSD-2c Public Domain
+OPENSSH_LICENSE_FILES = LICENCE
+OPENSSH_CONF_ENV = LD="$(TARGET_CC)" LDFLAGS="$(TARGET_CFLAGS)"
+OPENSSH_CONF_OPTS = \
+       --sysconfdir=/etc/ssh \
+       --disable-lastlog \
+       --disable-utmp \
+       --disable-utmpx \
+       --disable-wtmp \
+       --disable-wtmpx \
+       --disable-strip
+
+define OPENSSH_USERS
+       sshd -1 sshd -1 * - - - SSH drop priv user
+endef
+
+# uClibc toolchain for ARC doesn't support PIE at the moment
+ifeq ($(BR2_arc),y)
+OPENSSH_CONF_OPTS += --without-pie
+endif
+
+OPENSSH_DEPENDENCIES = zlib openssl
+
+ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
+OPENSSH_DEPENDENCIES += linux-pam
+OPENSSH_CONF_OPTS += --with-pam
+endif
+
+define OPENSSH_INSTALL_INIT_SYSTEMD
+       $(INSTALL) -D -m 644 package/openssh/sshd.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/sshd.service
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -fs ../../../../usr/lib/systemd/system/sshd.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/sshd.service
+endef
+
+define OPENSSH_INSTALL_INIT_SYSV
+       $(INSTALL) -D -m 755 package/openssh/S50sshd \
+               $(TARGET_DIR)/etc/init.d/S50sshd
+endef
+
+$(eval $(autotools-package))