The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / openobex / openobex.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/openobex/openobex.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/openobex/openobex.mk
new file mode 100644 (file)
index 0000000..82bfd43
--- /dev/null
@@ -0,0 +1,37 @@
+################################################################################
+#
+# openobex
+#
+################################################################################
+
+OPENOBEX_VERSION = 1.5
+OPENOBEX_SITE = http://ftp.osuosl.org/pub/linux/bluetooth
+# Libraries seems to be released under LGPLv2.1+,
+# while other material is under GPLv2+.
+OPENOBEX_LICENSE = GPLv2+/LGPLv2.1+
+OPENOBEX_LICENSE_FILES = COPYING COPYING.LIB
+
+OPENOBEX_DEPENDENCIES = host-pkgconf
+OPENOBEX_AUTORECONF = YES
+OPENOBEX_INSTALL_STAGING = YES
+
+OPENOBEX_CONF_OPTS += \
+       $(if $(BR2_PACKAGE_OPENOBEX_APPS),--enable-apps) \
+       $(if $(BR2_PACKAGE_OPENOBEX_SYSLOG),--enable-syslog) \
+       $(if $(BR2_PACKAGE_OPENOBEX_DUMP),--enable-dump)
+
+ifeq ($(BR2_PACKAGE_OPENOBEX_BLUEZ),y)
+OPENOBEX_DEPENDENCIES += bluez_utils
+OPENOBEX_CONF_OPTS += --with-bluez=$(STAGING_DIR)
+else
+OPENOBEX_CONF_OPTS += --disable-bluetooth
+endif
+
+ifeq ($(BR2_PACKAGE_OPENOBEX_LIBUSB),y)
+OPENOBEX_DEPENDENCIES += libusb
+OPENOBEX_CONF_OPTS += --with-usb=$(STAGING_DIR)
+else
+OPENOBEX_CONF_OPTS += --disable-usb
+endif
+
+$(eval $(autotools-package))