The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / on2-8170-libs / on2-8170-libs.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/on2-8170-libs/on2-8170-libs.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/on2-8170-libs/on2-8170-libs.mk
new file mode 100644 (file)
index 0000000..db68f02
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# on2-8170-libs
+#
+################################################################################
+
+ON2_8170_LIBS_VERSION = 1.0
+ON2_8170_LIBS_SITE = ftp://ftp.linux4sam.org/pub/demo/linux4sam_1.9/codec
+
+ON2_8170_LICENSE = PROPRIETARY
+# No license file is included in the archive
+
+ON2_8170_LIBS_INSTALL_STAGING = YES
+
+define ON2_8170_LIBS_INSTALL_STAGING_CMDS
+       mkdir -p $(STAGING_DIR)/usr/lib $(STAGING_DIR)/usr/include
+       cp -dpf $(@D)/*.a $(@D)/*.so $(STAGING_DIR)/usr/lib
+       cp -dpf $(@D)/*.h $(STAGING_DIR)/usr/include
+endef
+
+define ON2_8170_LIBS_INSTALL_TARGET_CMDS
+       mkdir -p $(TARGET_DIR)/usr/lib
+       cp -dpf $(@D)/*.so $(TARGET_DIR)/usr/lib
+endef
+
+$(eval $(generic-package))