The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / ofono / ofono.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/ofono/ofono.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/ofono/ofono.mk
new file mode 100644 (file)
index 0000000..f1a63e2
--- /dev/null
@@ -0,0 +1,49 @@
+################################################################################
+#
+# ofono
+#
+################################################################################
+
+OFONO_VERSION = 1.16
+OFONO_SOURCE = ofono-$(OFONO_VERSION).tar.xz
+OFONO_SITE = $(BR2_KERNEL_MIRROR)/linux/network/ofono
+OFONO_LICENSE = GPLv2
+OFONO_LICENSE_FILES = COPYING
+OFONO_DEPENDENCIES = \
+       host-pkgconf \
+       dbus \
+       libglib2 \
+       libcap-ng \
+       mobile-broadband-provider-info
+
+OFONO_CONF_OPTS = --disable-test
+
+# N.B. Qualcomm QMI modem support requires O_CLOEXEC; so
+# make sure that it is defined.
+OFONO_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
+
+define OFONO_INSTALL_INIT_SYSV
+       $(INSTALL) -m 0755 -D package/ofono/S46ofono $(TARGET_DIR)/etc/init.d/S46ofono
+endef
+
+define OFONO_INSTALL_INIT_SYSTEMD
+       mkdir -p $(TARGET_DIR)/etc/systemd/systemd/multi-user.target.wants
+       ln -fs ../../../../usr/lib/systemd/system/ofono.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+endef
+
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+OFONO_CONF_OPTS += --enable-udev
+OFONO_DEPENDENCIES += udev
+else
+OFONO_CONF_OPTS += --disable-udev
+endif
+
+ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
+OFONO_CONF_OPTS += --enable-bluetooth
+OFONO_DEPENDENCIES += bluez_utils
+else
+OFONO_CONF_OPTS += --disable-bluetooth
+endif
+
+$(eval $(autotools-package))