The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / noip / noip.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/noip/noip.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/noip/noip.mk
new file mode 100644 (file)
index 0000000..fceea1e
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# noip
+#
+################################################################################
+
+NOIP_VERSION = 2.1.9
+NOIP_SITE = http://www.no-ip.com/client/linux
+NOIP_SOURCE = noip-duc-linux.tar.gz
+NOIP_LICENSE = GPLv2+
+NOIP_LICENSE_FILES = COPYING
+
+define NOIP_BUILD_CMDS
+       sed -i -e "s:\(#define CONFIG_FILENAME\).*:\1 \"/etc/no-ip2.conf\":" \
+               $(@D)/noip2.c
+       $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+               PREFIX=/usr CONFDIR=/etc
+endef
+
+define NOIP_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/noip2 $(TARGET_DIR)/usr/sbin/noip2
+endef
+
+$(eval $(generic-package))