The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / ngrep / ngrep.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/ngrep/ngrep.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/ngrep/ngrep.mk
new file mode 100644 (file)
index 0000000..f2fcb73
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# ngrep
+#
+################################################################################
+
+NGREP_VERSION = 1.45
+NGREP_SOURCE = ngrep-$(NGREP_VERSION).tar.bz2
+NGREP_SITE = http://downloads.sourceforge.net/project/ngrep/ngrep/$(NGREP_VERSION)
+NGREP_LICENSE = BSD-4c-like
+NGREP_LICENSE_FILES = LICENSE.txt
+NGREP_INSTALL_STAGING = YES
+
+NGREP_LIBS = -lpcap -lpcre
+ifeq ($(BR2_STATIC_LIBS),y)
+NGREP_LIBS += $(shell $(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs)
+endif
+NGREP_CONF_ENV += LIBS+="$(NGREP_LIBS)"
+
+NGREP_CONF_OPTS =  \
+       --with-pcap-includes=$(STAGING_DIR)/usr/include/pcap \
+       --enable-pcre \
+       --with-pcre=$(STAGING_DIR)/usr \
+       --disable-dropprivs
+
+NGREP_DEPENDENCIES = libpcap pcre
+
+$(eval $(autotools-package))