The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / netplug / netplug.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/netplug/netplug.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/netplug/netplug.mk
new file mode 100644 (file)
index 0000000..0bd7c78
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# netplug
+#
+################################################################################
+
+NETPLUG_VERSION = 1.2.9.2
+NETPLUG_SOURCE = netplug-$(NETPLUG_VERSION).tar.bz2
+NETPLUG_SITE = http://www.red-bean.com/~bos/netplug
+NETPLUG_LICENSE = GPLv2
+NETPLUG_LICENSE_FILES = COPYING
+
+define NETPLUG_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define NETPLUG_INSTALL_TARGET_CMDS
+       $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+define NETPLUG_INSTALL_INIT_SYSV
+       $(INSTALL) -m 0755 -D package/netplug/S29netplug \
+               $(TARGET_DIR)/etc/init.d/S29netplug
+endef
+
+$(eval $(generic-package))