The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / netperf / netperf.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/netperf/netperf.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/netperf/netperf.mk
new file mode 100644 (file)
index 0000000..13d44fe
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# netperf
+#
+################################################################################
+
+NETPERF_VERSION = 2.6.0
+NETPERF_SITE = ftp://ftp.netperf.org/netperf
+NETPERF_CONF_ENV = ac_cv_func_setpgrp_void=set
+NETPERF_CONF_OPTS = --enable-demo=yes
+NETPERF_LICENSE = netperf license
+NETPERF_LICENSE_FILES = COPYING
+
+define NETPERF_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 $(@D)/src/netperf \
+               $(TARGET_DIR)/usr/bin/netperf
+       $(INSTALL) -m 0755 $(@D)/src/netserver \
+               $(TARGET_DIR)/usr/bin/netserver
+endef
+
+$(eval $(autotools-package))