The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / nbd / nbd.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/nbd/nbd.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/nbd/nbd.mk
new file mode 100644 (file)
index 0000000..fee2cf8
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# nbd
+#
+################################################################################
+
+NBD_VERSION = 3.11
+NBD_SOURCE = nbd-$(NBD_VERSION).tar.xz
+NBD_SITE = http://downloads.sourceforge.net/project/nbd/nbd/$(NBD_VERSION)
+NBD_CONF_OPTS = --enable-lfs
+NBD_DEPENDENCIES = libglib2
+NBD_LICENSE = GPLv2
+NBD_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+# We have linux/falloc.h
+# but uClibc lacks fallocate(2) which is a glibc-ism
+NBD_CONF_ENV = ac_cv_header_linux_falloc_h=no
+endif
+
+ifneq ($(BR2_NBD_CLIENT),y)
+NBD_TOREMOVE += nbd-client
+endif
+ifneq ($(BR2_NBD_SERVER),y)
+NBD_TOREMOVE += nbd-server
+endif
+
+define NBD_CLEANUP_AFTER_INSTALL
+       rm -f $(addprefix $(TARGET_DIR)/usr/sbin/, $(NBD_TOREMOVE))
+endef
+
+NBD_POST_INSTALL_TARGET_HOOKS += NBD_CLEANUP_AFTER_INSTALL
+
+$(eval $(autotools-package))