The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / mtr / mtr.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/mtr/mtr.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/mtr/mtr.mk
new file mode 100644 (file)
index 0000000..3f73a5f
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# mtr
+#
+################################################################################
+
+MTR_VERSION = v0.86
+MTR_SITE = $(call github,traviscross,mtr,$(MTR_VERSION))
+MTR_AUTORECONF = YES
+MTR_CONF_OPTS = --without-gtk
+MTR_DEPENDENCIES = host-pkgconf $(if $(BR2_PACKAGE_NCURSES),ncurses)
+MTR_LICENSE = GPLv2
+MTR_LICENSE_FILES = COPYING
+
+# uClibc has res_ninit but not res_nmkquery
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+define MTR_DISABLE_RES_NINIT
+       $(SED) 's/#ifdef res_ninit/#if 0/' \
+               $(@D)/dns.c
+endef
+endif
+
+MTR_POST_PATCH_HOOKS += MTR_DISABLE_RES_NINIT
+
+$(eval $(autotools-package))