The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / mtools / mtools.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/mtools/mtools.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/mtools/mtools.mk
new file mode 100644 (file)
index 0000000..d331af2
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# mtools
+#
+################################################################################
+
+MTOOLS_VERSION = 4.0.18
+MTOOLS_SOURCE = mtools-$(MTOOLS_VERSION).tar.bz2
+MTOOLS_SITE = $(BR2_GNU_MIRROR)/mtools
+MTOOLS_LICENSE = GPLv3+
+MTOOLS_LICENSE_FILES = COPYING
+MTOOLS_CONF_ENV = ac_cv_func_setpgrp_void=yes
+MTOOLS_CONF_OPTS = --without-x
+
+# link with iconv if enabled
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+MTOOLS_DEPENDENCIES += libiconv
+MTOOLS_CONF_ENV += LIBS=-liconv
+# We have no host dependencies
+HOST_MTOOLS_DEPENDENCIES =
+endif
+
+# Package does not build in parallel due to improper make rules
+MTOOLS_MAKE = $(MAKE1)
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))