The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / mp4v2 / mp4v2.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/mp4v2/mp4v2.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/mp4v2/mp4v2.mk
new file mode 100644 (file)
index 0000000..d34de02
--- /dev/null
@@ -0,0 +1,31 @@
+################################################################################
+#
+# mp4v2
+#
+################################################################################
+
+MP4V2_VERSION = 2.0.0
+MP4V2_SOURCE = mp4v2-$(MP4V2_VERSION).tar.bz2
+MP4V2_SITE = https://mp4v2.googlecode.com/files
+MP4V2_INSTALL_STAGING = YES
+MP4V2_LICENSE = MPLv1.1
+MP4V2_LICENSE_FILES = COPYING
+
+# help2man expects to be able to run utilities on the build machine to
+# grab --help output which doesn't work when cross compiling, so
+# disable it
+MP4V2_CONF_ENV = ac_cv_prog_FOUND_HELP2MAN=no
+
+# infrastructure passes --disable-debug if !BR2_ENABLE_DEBUG. With
+# mpv42 the only thing this option does is that it tries to strip any
+# -g* options from CFLAGS/CXXFLAGS. The logic to do so is
+# unfortunately buggy, so just pass --enable-debug to disable this
+MP4V2_CONF_OPTS = --enable-debug --enable-largefile
+
+ifeq ($(BR2_PACKAGE_MP4V2_UTIL),y)
+MP4V2_CONF_OPTS += --enable-util
+else
+MP4V2_CONF_OPTS += --disable-util
+endif
+
+$(eval $(autotools-package))