The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / monit / monit.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/monit/monit.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/monit/monit.mk
new file mode 100644 (file)
index 0000000..9f0a29a
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# monit
+#
+################################################################################
+
+MONIT_VERSION = 5.12.2
+MONIT_SITE = http://mmonit.com/monit/dist
+MONIT_LICENSE = AGPLv3 with OpenSSL exception
+MONIT_LICENSE_FILES = COPYING
+#
+# Touching Makefile.am:
+MONIT_AUTORECONF = YES
+
+MONIT_CONF_ENV = \
+       libmonit_cv_setjmp_available=yes \
+       libmonit_cv_vsnprintf_c99_conformant=yes
+
+MONIT_CONF_OPTS += \
+       --without-pam \
+       --with-largefiles
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MONIT_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
+MONIT_DEPENDENCIES += openssl
+else
+MONIT_CONF_OPTS += --without-ssl
+endif
+
+$(eval $(autotools-package))