The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / mongrel2 / mongrel2.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/mongrel2/mongrel2.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/mongrel2/mongrel2.mk
new file mode 100644 (file)
index 0000000..23cec50
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# mongrel2
+#
+################################################################################
+
+MONGREL2_VERSION = v1.9.1
+# Do not use the github helper here, the generated tarball is *NOT* the same
+# as the one uploaded by upstream for the release.
+MONGREL2_SITE = https://github.com/zedshaw/mongrel2/releases/download/$(MONGREL2_VERSION)
+MONGREL2_LICENSE = BSD-3c
+MONGREL2_LICENSE_FILES = LICENSE
+MONGREL2_DEPENDENCIES = sqlite zeromq
+
+define MONGREL2_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               PREFIX=/usr all
+endef
+
+define MONGREL2_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               PREFIX=/usr DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))