The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / modplugtools / modplugtools.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/modplugtools/modplugtools.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/modplugtools/modplugtools.mk
new file mode 100644 (file)
index 0000000..e8d73af
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# modplugtools
+#
+################################################################################
+
+MODPLUGTOOLS_VERSION = 0.5.3
+MODPLUGTOOLS_SITE = http://downloads.sourceforge.net/project/modplug-xmms/modplug-tools
+MODPLUGTOOLS_LICENSE = GPLv3
+MODPLUGTOOLS_LICENSE_FILES = COPYING
+
+MODPLUGTOOLS_DEPENDENCIES = libao libmodplug
+
+# Only build the 'mp123' subdir, which contains 'modplug123' that plays through
+# various backends via libao. This excludes the 'mpplay' subdir, which contains
+# 'modplugplay' that can play only through the deprecated OSS interface.
+MODPLUGTOOLS_MAKE_OPTS = SUBDIRS=mp123
+MODPLUGTOOLS_INSTALL_TARGET_OPTS = SUBDIRS=mp123 DESTDIR=$(TARGET_DIR) install
+
+$(eval $(autotools-package))