The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / mesa3d / 0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/mesa3d/0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/mesa3d/0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch
new file mode 100644 (file)
index 0000000..5dc9099
--- /dev/null
@@ -0,0 +1,39 @@
+From 83a1afd73f2d0aff9aa11c1754d6d407983afa7d Mon Sep 17 00:00:00 2001
+From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Date: Wed, 9 Apr 2014 12:48:36 +0200
+Subject: [PATCH] Fix khrplatform.h not installed if EGL is disabled.
+
+KHR/khrplatform.h is required by the EGL, GLES and VG headers, but is
+only installed if Mesa3d is compiled with EGL support.
+
+This patch installs this header file unconditionally.
+
+Patch sent upstream: https://bugs.freedesktop.org/show_bug.cgi?id=77240
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> (rebased for mesa3d 10.3)
+
+diff -uNr Mesa-10.3.0-rc2.org/src/egl/main/Makefile.am Mesa-10.3.0-rc2/src/egl/main/Makefile.am
+--- Mesa-10.3.0-rc2.org/src/egl/main/Makefile.am       2014-08-29 00:00:57.000000000 +0200
++++ Mesa-10.3.0-rc2/src/egl/main/Makefile.am   2014-09-02 21:35:52.548071820 +0200
+@@ -85,9 +85,6 @@
+ pkgconfig_DATA = egl.pc
+-khrdir = $(includedir)/KHR
+-khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
+-
+ egldir = $(includedir)/EGL
+ egl_HEADERS = \
+       $(top_srcdir)/include/EGL/eglext.h \
+diff -uNr Mesa-10.3.0-rc2.org/src/mapi/Makefile.am Mesa-10.3.0-rc2/src/mapi/Makefile.am
+--- Mesa-10.3.0-rc2.org/src/mapi/Makefile.am   2014-09-01 01:22:12.000000000 +0200
++++ Mesa-10.3.0-rc2/src/mapi/Makefile.am       2014-09-02 21:36:22.891686861 +0200
+@@ -211,4 +211,7 @@
+ SUBDIRS += vgapi
+ endif
++khrdir = $(includedir)/KHR
++khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
++
+ include $(top_srcdir)/install-lib-links.mk