The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / memtest86 / memtest86.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/memtest86/memtest86.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/memtest86/memtest86.mk
new file mode 100644 (file)
index 0000000..ef98f61
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# memtest86
+#
+################################################################################
+
+MEMTEST86_VERSION = 4.20
+MEMTEST86_SOURCE = memtest86+-$(MEMTEST86_VERSION).tar.gz
+MEMTEST86_SITE = http://www.memtest.org/download/$(MEMTEST86_VERSION)
+MEMTEST86_LICENSE = GPLv2
+MEMTEST86_LICENSE_FILES = README
+
+# memtest86+ is sensitive to toolchain changes, use the shipped binary version
+define MEMTEST86_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/precomp.bin $(TARGET_DIR)/boot/memtest86+.bin
+endef
+
+$(eval $(generic-package))
+