The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / memstat / memstat.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/memstat/memstat.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/memstat/memstat.mk
new file mode 100644 (file)
index 0000000..7ee4d60
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# memstat
+#
+################################################################################
+
+MEMSTAT_VERSION = 1.0
+MEMSTAT_SITE = http://downloads.sourceforge.net/project/memstattool
+MEMSTAT_SOURCE = memstat_$(MEMSTAT_VERSION).tar.gz
+MEMSTAT_LICENSE = GPL
+MEMSTAT_LICENSE_FILES = debian/copyright
+
+define MEMSTAT_BUILD_CMDS
+       $(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" CFLAGS="$(TARGET_CFLAGS)" \
+               -C $(@D) memstat
+endef
+
+define MEMSTAT_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/memstat.conf -m 0644 \
+               $(TARGET_DIR)/etc/memstat.conf
+       $(INSTALL) -D $(@D)/memstat $(TARGET_DIR)/usr/bin/memstat
+endef
+
+$(eval $(generic-package))