The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / matchbox / matchbox-panel / matchbox-panel.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/matchbox/matchbox-panel/matchbox-panel.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/matchbox/matchbox-panel/matchbox-panel.mk
new file mode 100644 (file)
index 0000000..d3efed9
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# matchbox-panel
+#
+################################################################################
+
+MATCHBOX_PANEL_VERSION_MAJOR = 0.9
+MATCHBOX_PANEL_VERSION = $(MATCHBOX_PANEL_VERSION_MAJOR).3
+MATCHBOX_PANEL_SOURCE = matchbox-panel-$(MATCHBOX_PANEL_VERSION).tar.bz2
+MATCHBOX_PANEL_SITE = http://downloads.yoctoproject.org/releases/matchbox/matchbox-panel/$(MATCHBOX_PANEL_VERSION_MAJOR)
+MATCHBOX_PANEL_LICENSE = GPLv2+
+MATCHBOX_PANEL_LICENSE_FILES = COPYING
+MATCHBOX_PANEL_DEPENDENCIES = matchbox-lib
+MATCHBOX_PANEL_CONF_OPTS = --enable-expat
+
+ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
+MATCHBOX_PANEL_CONF_OPTS += --enable-startup-notification
+MATCHBOX_PANEL_DEPENDENCIES += startup-notification matchbox-startup-monitor
+else
+MATCHBOX_PANEL_CONF_OPTS += --disable-startup-notification
+endif
+
+ifeq ($(BR2_PACKAGE_WIRELESS_TOOLS),y)
+MATCHBOX_PANEL_DEPENDENCIES += wireless_tools
+endif
+
+$(eval $(autotools-package))