The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / madplay / madplay.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/madplay/madplay.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/madplay/madplay.mk
new file mode 100644 (file)
index 0000000..ff12aa1
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# madplay
+#
+################################################################################
+
+MADPLAY_VERSION = 0.15.2b
+MADPLAY_SITE = http://downloads.sourceforge.net/project/mad/madplay/$(MADPLAY_VERSION)
+MADPLAY_LICENSE = GPLv2+
+MADPLAY_LICENSE_FILES = COPYING COPYRIGHT
+MADPLAY_LIBTOOL_PATCH = NO
+MADPLAY_DEPENDENCIES = libmad libid3tag $(if $(BR2_PACKAGE_GETTEXT),gettext)
+
+# Check if ALSA is built, then we should configure after alsa-lib so
+# ./configure can find alsa-lib.
+ifeq ($(BR2_PACKAGE_MADPLAY_ALSA),y)
+MADPLAY_CONF_OPTS += --with-alsa
+MADPLAY_DEPENDENCIES += host-pkgconf alsa-lib
+MADPLAY_CONF_ENV += LIBS="$(shell $(PKG_CONFIG_HOST_BINARY) --libs alsa)"
+endif
+
+$(eval $(autotools-package))