The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / luaposix / luaposix.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/luaposix/luaposix.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/luaposix/luaposix.mk
new file mode 100644 (file)
index 0000000..ea4ab02
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# luaposix
+#
+################################################################################
+
+LUAPOSIX_VERSION = 33.3.1
+LUAPOSIX_SITE = $(call github,luaposix,luaposix,release-v$(LUAPOSIX_VERSION))
+LUAPOSIX_LICENSE = MIT
+LUAPOSIX_LICENSE_FILES = COPYING
+LUAPOSIX_DEPENDENCIES = luainterpreter host-lua ncurses
+LUAPOSIX_CONF_OPTS = --libdir="/usr/lib/lua/$(LUAINTERPRETER_ABIVER)" --datarootdir="/usr/share/lua/$(LUAINTERPRETER_ABIVER)"
+
+$(eval $(autotools-package))